MainDoctor WhoMusicSoftware
Main Page

Alden Bates' Weblog

Feigning normality since 1973

OB Movable Type 4.0 upgrade post

Filed in: Movable Type.

Well, isn't this user interface spanky and new? I've upgraded this weblog to MT 4.0. Do I like it? Hmmm, I don't know.

Usually when updating, I have to laboriously upload each file, because I keep them in different places to where they are in the zip file Sixapart gives me. This time I thought I'd be clever, so I rearranged them on my PC, made an archive file, uploaded it and extracted it on the server. Unfortunately I forgot that when I create a tar.gz on Window XP and unzip it on Linux, all the directories get created without their execute bits, and everything breaks. Ho hum.

The second hurdle was that the update wizard would not recognise my mt-static directory. It turned out that this was because it was trying to load mt.js by going through the web server, and it was using a libwww-perl user agent, which I have blocked in .htaccess (because a hacker uses it when he tries to hack my server), so I had to amend my .htaccess.

My only other problem was getting it to recognise one of my plugins (archivedateheader), which was fixed by changing the directory and filename of the plugin to all lower case (WTF?).

Now, what are the odds that when I hit the "Save" button, the whole thing will come crashing down in a heap?

Edit: It worked! But where has the list of categories gone from my index page? :P

Editedit: Fixed, I had to turn the MTSubCategories tags into MTTopLevelCategories tags. :P

Edit³: When I try to rebuild all categories, it says "An error occurred publishing category '1': Publish error in template 'Category Archive': Error in <mt:HasParentCategory> tag". I think I'm done with wrestling with it tonight though.

Posted August 16, 2007 8:35 PM

Comments

This is a test of the emergency commenting system.

Also, it says I made the post immediately prior to this one "1 day ago", but it was two days ago!

Posted by: Alden | August 16, 2007 9:08 PM

So, does this break your paged archive thing?

Posted by: Thad Ritchards | August 17, 2007 7:28 AM

Nope, that plugin seems to be working fine (wonder upon wonders :)

Posted by: Alden Bates | August 17, 2007 8:43 AM

I note the front page now only has one weblog entry on it instead of three...

Posted by: Anonymous | August 17, 2007 1:56 PM

So it has - fixed! Thank you. :)

Posted by: Alden Bates | August 17, 2007 2:02 PM

Post a comment





Tetrap.com Site Map